vpnAlert.com

How to Set Up and Use NordVPN on MikroTik?

We are reader supported and may earn a commission when you buy through links on our site. Learn more.

You can set up and use NordVPN on MikroTik by running a few setup commands in the MikroTik panel.

A MikroTik router provides multiple configuration options to connect you to the internet. When you add NordVPN to the mix, you can unblock content anywhere, improve your internet privacy and protect devices (like Smart TVs) that can’t download a VPN app.

In this guide, I’ll give you a step-by-step guide to set up and use NordVPN on MikroTik.

How to Setup NordVPN on MikroTik? (Step-By-Step Guide)

nordvpn on mikrotik configuration

Setting up NordVPN on MikroTik requires selecting your preferred NordVPN server and securing your web connection by following a few steps.

I found a helpful video to set up NordVPN on MikroTik:

You can also continue with the guide below if you aren’t watching the video yet, or want a supplementary guide:

  1. Go to your MikroTik RouterOS settings and open a terminal.
  2. Download and import NordVPN’s root CA certificate. To do this, run the command below:
				
					/tool fetch url=“https://downloads.nordcdn.com/certificates/root.der”

/certificate import file-name=root.der
				
			
  1. Run the command below to confirm that the certificate has been imported successfully.
				
					/certificate print where name~ “root.der”
				
			
  1. Get the hostname for your preferred VPN server from NordVPN’s server tools. NordVPN can recommend the best server based on your location.
nordvpn server tools
  1. Set up the IPsec tunnel by creating a separate Phase 1 profile and Phase 2 proposal configuration. To do this, run the command below in the terminal.
				
					/ip ipsec profile

add name=NordVPN

/ip ipsec proposal

add name=NordVPN pfs-group=none
				
			
  1. Create a New Policy Group and Template for a unique IPsec configuration by running the command below:
				
					/ip ipsec policy group

add name=NordVPN

/ip ipsec policy

add dst-address=0.0.0.0/0 group=NordVPN proposal=NordVPN src-address=0.0.0.0/0 template=yes
				
			
  1. Create a “New Mode Configuration Entry” with a responder value of “No.” Then, enter the command below in the terminal.
				
					/ip ipsec mode-config

add name=NordVPN responder=no
				
			
  1. Create peer and identity configurations. The command below will help you establish a connection.
				
					/ip ipsec peer

add address=lv20.nordvpn.com exchange-mode=ike2 name=NordVPN profile=NordVPN

/ip ipsec identity

add auth-method=eap certificate=”” eap-methods=eap-mschapv2 generate-policy=port-strict mode-config=NordVPN peer=NordVPN policy-template-group=NordVPN username=YourNordVPNServiceUsername password=YourNordVPNServicePassword
				
			
  1. Input your NordVPN credentials in the username and password parameters. Note that the details you’ll enter here aren’t your NordVPN login credentials. You should go through your NordVPN account > Services > Advanced Configuration > Service Credentials > Username and Password to get the correct information.
nordvpn account
nordvpn advanced configuration
  1. Enter the command below to ensure that the connection is successful.
				
					/ip ipsec

active-peers print

installed-sa print
				
			
  1. Choose what you send through the VPN tunnel. You can use the command below to create your new IP/Firewall/Address list.
				
					/ip firewall address-list

Add address=192.168.1.0/24 list=local
				
			
  1. Optional: If you prefer using single or multiple IP addresses, use this command:
				
					/ip firewall address-list

add address=192.168.1.120 list=local

add address=192.168.1.80 list=local
				
			
  1. Attach the IP/Firewall/Address list to mode config configuration using the command below.
				
					/ip ipsec mode-config

set [ find name=NordVPN ] src-address-list=local
				
			
  1. Confirm that the NAT rule is generated dynamically when the tunnel is set up by using the command below.
				
					/ip firewall nat print
				
			
  1. You can now use NordVPN with your MikroTik device.

Benefits of Using NordVPN on MikroTik

Combining NordVPN and MikroTik allows you to enjoy a premium, secure internet experience. Here are some other benefits to convince you:

  • Thousands of global servers. NordVPN boasts 5200+ global servers in 59 countries and 2100+ US servers in 15 locations. This allows you to quickly gain access to geo-restricted services, including on streaming platforms like Netflix and Hulu.
  • Multiple device compatibility. You can use NordVPN on six simultaneously connected devices spanning iOS, Windows, Linux, Mac, Android devices and your MikroTik router. You can also get more slots to use the VPN with unlimited devices when you set it up with MikroTik.
  • Security. NordVPN provides maximum protection with advanced security features and AES-256 encryption to neutralize third-party threats and ensure internet data safety.
  • Speed. NordVPN provides a smooth and fast internet connection with little to no lags.
  • Privacy. NordVPN guarantees privacy with its strict no-logs policy. It’s located in Panama, which isn’t a part of the 5/9/14 Eyes, ensuring your data is safe and won’t be shared with third parties (like the government).
  • Reliable customer support. If you ever have difficulty using NordVPN on your MikroTik router, the VPN service provider has a highly dedicated customer support service available 24/7 to help solve the issues.

Quick Tips to Follow if Your NordVPN App Isn’t Working

troubleshoot nordvpn configured to mikrotik

You may have followed all the steps mentioned above, but your NordVPN-MikroTik connection isn’t working. In that case, follow the tips below to resolve this issue:

  • Check your internet connection. If your NordVPN app isn’t working after carefully following the right steps, you may not have a stable internet connection. To solve this, refresh your internet, test the connection speed, check that the internet is active and connect again.
  • Disable antivirus or firewall software. An antivirus or firewall software could be a problem if you’re using a computer or laptop. Disable it, or add the NordVPN connection to an exclusion list and connect again.
  • Switch servers. Your chosen server may be suffering overcrowding, under maintenance, have IP issues or be down for other reasons. So, switch to a different one.
  • Verify your NordVPN credentials. Double-check the NordVPN credentials you entered during your MikroTik setup to ensure you have the correct information.

FAQs

The best NordVPN protocol on MikroTik is OpenVPN because it’s the most stable and secure protocol for routers. However, NordVPN’s OpenVPN isn’t available on MikroTik, leaving IKEv2 as the next best protocol. Luckily, it’s also a versatile software that uses strong encryption algorithms for reliable security.

You can specify which traffic to hide in a NordVPN tunnel on MikroTik.

Thus, leaving sensitive and location-specific traffic, like banking apps, online payment systems, online gaming, and shopping apps, out of the VPN tunnel.

In Conclusion

If you’ve chosen to use NordVPN with your MikroTik router, you’ve made the right choice. Now, all your devices can be protected with NordVPN’s first-rate security, privacy, and unblocking services.

Ready to get started? Grab these NordVPN discounts to save more on your purchase.

Try NordVPN Risk-Free!
Protect private web traffic from snooping, interference, and censorship. All plans are covered by a no-hassle 100% money-back guarantee for your first 30 days of service.
Explore More
NordVPN deal
NEW YEAR DEAL!
Our partner, NordVPN, is offering an exclusive discount for a limited time! Don't miss out on the chance to save extra money.​
OFFER EXPIRES IN:
Hours
Minutes
Seconds
TODAY!
VIEW EXCLUSIVE OFFER
No thanks, I can try NordVPN for FREE